導航:首頁 > 電腦設置 > eclipse電腦配置要求

eclipse電腦配置要求

發布時間:2022-07-01 18:46:58

A. JAVA編譯器eclipse對於電腦的最低配置要求

eclipse主要消耗內存比較大。我做java開發,根據我的實際經驗。最少是1G的內存。其它的要求並不高。

B. 程序員的電腦需要什麼樣的配置

程序員的電腦需要的配置:

1.適合的系統:Windows系的用Windows,Linux系的用Linux或者Mac。總之要和自己的需求一致,別給自己找到麻煩。

2.舒服的交互硬體。4k屏用不用的到不好說但是一個27寸以上的顯示器人人都喜歡。雙顯很有用,三顯不好說。因為我們總要開各種資料/網頁,IDE,命令行編輯器什麼的,小顯示器你就慢慢惡心吧。機械鍵盤或者hhkb請上一個。

3.內存要大,CPU要快,硬碟要SSD。開一堆網頁,開IDE都是很占資源的。編譯的速度影響工作效率與心情。

4.通暢的網路環境。

5.其他配置根據不同的需求而定。比如跑GPU的,圖形開發的顯卡要給力一些。經常出差的還要配個輕便續航強的筆記本。

C. 使用eclipse對電腦硬體配置有什麼要求嗎

您好,這樣的機器建議您不要購買,幾乎幹不了什麼事情。這樣的機器已經很老了,配件能否正常工作,還是個問題。512M的內存運行xp系統,再加上殺毒軟體已經很吃力了,再運行您說的這些程序就別說了。
建議您還是多花點錢,現在外面新機器1500元就能買到一個主機,加上好一點的顯示器也就是2500元就能配到可以裝win7系統的,運行您說的這些軟體是不成問題的。

D. Eclipse怎麼配置運行環境

eclipse需要配置環境變數

方法/步驟

  1. 右鍵「我的電腦」圖標,在彈出菜單中依次選擇「屬性」-「高級」-「環境變數」。

  2. 配置完成後啟動eclipse,它會自動完成對JAVA環境的配置。

E. 裝Eclipse至少需要怎麼樣的電腦配置

eclipse也就是集成開發環境,對電腦配置要求並不是很高,主流的I3/I5/I7處理器都可以安裝的。

  1. Eclipse 是一個開放源代碼的、基於Java的可擴展開發平台。就其本身而言,它只是一個框架和一組服務,用於通過插件組件構建開發環境,Eclipse 附帶了一個標準的插件集,包括Java開發工具(Java Development Kit,JDK)。

  2. Eclipse 可以當作 Java集成開發環境(IDE)來使用,但 Eclipse 的目標卻不僅限於此。Eclipse 還包括插件開發環境(Plug-in Development Environment,PDE),這個組件主要針對希望擴展 Eclipse 的軟體開發人員,因為它允許他們構建與 Eclipse 環境無縫集成的工具。由於 Eclipse 中的每樣東西都是插件,對於給 Eclipse 提供插件,以及給用戶提供一致和統一的集成開發環境而言,所有工具開發人員都具有同等的發揮場所。

F. 寫程序一般要求電腦什麼配置

買個四核的CPU,配上足夠的內存,加上鏡像硬碟陣列,配一個不錯的耳機
雙路坑定比單路快,編譯軟體當然要用高主頻。不過,你不一定非要找個高配的機器。可以租借。畢竟主要任務是寫程序。
簡單的程序的話,隨便一個電腦都行
希望得到您的好評
~在右上角點擊【評價】,然後就可以選擇【滿意,問題已經完美解決】了。
如果你認可我的回答,敬請及時採納,
~你的採納是我前進的動力~~
O(∩_∩)O,記得好評和採納,互相幫助
————————來自【莫悠專屬】團隊只為莫悠的回答!

G. 軟體開發對電腦配置要求高嗎

Win、Mac、Linux是常用的三大操作系統,因為不同的崗位需求對不同的電腦性能要求也不一樣。比如像前端開發、後端開發、運維、演算法、嵌入式等這些崗位的要求都還不太一樣。
1.前端開發
不管是用「三件套」的原生技術棧時代,也就是所謂的html、css、javascript。還是後來的「封裝庫」時代,也就是有了jQury和ajax的時代。亦或是現在如今比較火的「組件式」開發時代,有angular、react、Vue這些組件化框架開發時代。我們以最新的為例來說:首先,你一般會需要一個命令行終端,然後前端開發也需要一個比較大的IDE環境,現在我看好像用webstorm比較多,前端開發再厲害點的就還需要一個vscode或者是atom也就是文本編譯器,最後就還需要一個瀏覽器。所以前端開發常見也就使用這個四五個開發軟體,所以說前端開發對於電腦性能沒什麼要求,因為它不怎麼吃電腦性能沒有什麼特殊要求,正常配置就可以了。當然唯一的要求可能就是屏幕解析度和屏幕色准,不管怎麼說都是跟圖形化的東西打交道。所以從這些角度上來講,我是推薦還是用一台Mac來做前端開發比較好,因為它屏幕還是挺不錯的。關於顯卡的話,顯卡不是必須的,但是具備最好,因為前段也有可能會接觸到一些UI設計方面的應用軟體。綜上所說,前段其實不耗電腦性能:8G內存,一個固態SSD基本上就夠了。
2.後端開發
以java後端開發為例,需要一個大的IDE,一般是eclipse或者是intellij IDEA(後者現在更多)、瀏覽器(Google)、而資料庫可視化可能需要類似於Navicat這種軟體、前後端調試介面需要Postman、編輯器vscode或者是atom、後端開發也需要命令行終端、遠程連接伺服器就需要一個SSH終端。當時我在自己2016款中配MacBook pro上做過實驗,把java開發的所需要的軟體全部打開會耗費多少性能。實驗證明我自己的這台16款中配8G內存的MacBook pro是非常能勝任的,運行非常流暢。後端開發的話我建議內存盡量8G及以上、系統盤是SSD(256G)基本夠了、顯卡就看自己的喜好就行,如果你要搞大數據、虛擬化、編程環境復雜一些的技術,需要虛擬機支持的話就需要你的電腦CPU、內存、硬碟都得要再上一個台階了。
1.AI(人工智慧)
如果你是做AI、機器學習、圖形圖像處理演算法,除了在CPU、硬碟、內存(16G+)要求比較高之外還需要GPU的加持。因為我們以前在實驗室做圖形圖像處理和一些模式處理的演算法的時候就會用到並行計算,這個時候就需要GPU的加速了。
4.運維
其實我覺得運維崗對客戶端機要求是最低的,因為運維絕大部分時間都是在一個遠程終端連接到一個遠程伺服器上去進行操作。所以你本地客戶機基本上一個SSH終端就能搞定一切,厲害些的可能就還需要一些文件對比工具和編譯器等,很小的一些小工具就可以了。
5.嵌入式開發
如果你是做嵌入式開發或者跟硬體打交道的話,那盡量還是在Windows或則是Linux下做比較好,Mac不是一個好的選擇,因為Mac上很多嵌入式開發的軟體確實是沒有。
所以說在大部分情況下我還是覺得一台中配的MacBook pro就可以搞定一切,最好是15寸的(效率相對而言高一些),具體哪一款的話,我自己用過:14、15、16、17、18款都用過,在我感覺16款的體驗稍微的好一點點,但是差別也沒那麼大,因人而議。如果說你MacBook pro不想買新的話,買一個二手的也是不錯的選擇,像14款的中配MacBook pro就是13寸的8G內存156G基本上也就是4000多塊錢。而15款二手的MF840差不多也就賣5000塊錢。我自己的現在是16款的帶Touch Bar的這個MacBook pro 8G內存、256SSD、i5處理器的話頂天也就只能賣一個7000塊錢。所以說二手的性價比是最高的。除了MacBook pro之外的話還有ThinkPad T系列也還不錯。

H. 怎樣配置eclipse

1:基本環境以及要求
Eclipse 3.01
Tomcat 4.1.30也可以是其它版本的,但最好是4.0以上的。
J2SDK 1.4.2
Lomboz301
emf-sdo-runtime-2.0.1
Java和Tomcat一定要事先都安裝好,並且tomcat單獨啟動要沒有問題才可以。同時也要把JAVA_HOME\jre\lib\rt.jar這個文件加到classpath中去。
2:事先准備
先將emf-sdo-runtime-2.0.1和Lomboz301中的各個文件解壓到Eclipse對應的plugins或features目錄中去。啟動Eclipse,如果出現看不到Lomboz的情況時,先退出Eclipse,然後把Eclipse目錄configuration中下面的 org.eclipse.update文件夾刪掉,再重新啟動Eclipse就可以了。
3:配置Java
在Eclipse中點擊windows->preferences,在出現的窗口中選擇java->Installed JRES,這時可以在右邊的窗口中看到己經有一項目,名字為j2re1.4.2_04。我們再在這里點擊右面的"Add"按鈕,增加一個JRE,在出現的對話框中輸入:
JRE Type: Standard VM
JRE name: 可以隨意輸入一個名字
JRE home directory:這里選擇你的JDK的安裝目錄,好比你的JDK裝在F:\J2SDK\,那麼這里就是選擇F:\J2SDK\這個目錄。
其它的可以都不管,點擊OK就新增了一個JRE了。

這里修改完了之後回到preferences對話框中的Java->Build Path這一項,點擊Build Path後,在右面的面板中我們選擇Source and output folder下面的Folders這一項,而兩個Source folder name和Output folder name的值我們不修改,保存為系統默認值,但是下面的As JRE library use:我們要選擇為JRE_LIB variable這一項,不能為默認值JRE container,最後點擊下面的Apply按鈕。這一步千萬不要忘記了,不然剛才的都是白做了。

4:設置Lomboz
在Preferences窗口中選定Lomboz,然後把右邊面板中的JDK Tools.jar選擇為你安裝好JDK後,在JAVA_HOME\LIB\目錄下面的tools.jar文件就可以了,一定不要搞錯了,如果你的JDK 是安裝在F:\J2SDK\下面,那麼這里的值就應該是F:\J2SDK\lib\tools.jar,是其它的都不對。其它的保持為默認值。
接著把Lomboz這一項展開,關鍵要設置的地方是Server Definitions這一項,另外兩項Code Generation和JSP Editor可以不管。展開Lomboz的Server Definitions後,在Server types里選擇Apache Tomcat v4.1.0(這是按照我的機器上的配置進行設置的,如果你安裝的是其它版本的TOMCAT,你就要選擇對應的選項),主要設置如下:
Properties
Application Server Directory:這是我的TOMCAT 4.1.30的安裝目錄,我裝在F:\tomcat下面,所以它的值就是F:/tomcat
Address:127.0.0.1
Port:80(因為我在TOMCAT中把8080改為80了,所以這里就是80了,以你的TOMCAT的監聽埠為准)
Classpath Variable Name: TOMCAT_HOME(可以修改成其它的字元串)
Classpath Variable: F:/tomcat(TOMCAT的安裝目錄)
然後點擊Apply按鈕。
Server Classpath:
JDK_TOOLS
${classPathVariableName}/bin/bootstrap.jar
${classPathVariableName}/common/servlet.jar
${classPathVariableName}/common/jasper-runtime.jar
然後點擊Apply按鈕。

Client Classpath:
這里為空,什麼也沒有。

Project Classpath:
JDK_TOOLS
${classPathVariableName}/bin/bootstrap.jar
${classPathVariableName}/common/servlet.jar
${classPathVariableName}/common/jasper-runtime.jar
然後點擊Apply按鈕。
這里的 Server Classpath:和Project Classpath:我設置的是一樣的。

5:修改文件
把Eclipse_home\plugins\com.objectlearn.jdt.j2ee_3.0.1\servers 下面對應的server文件打開,比如我安裝的TOMCAT是4.1.30版的,那麼就把tomcat410.server這個文件打開,把裡面的 -Djava.endorsed.dirs="${serverRootDirectory}/bin;${serverRootDirectory}/common/endorsed"
改成
-Djava.endorsed.dirs="${serverRootDirectory}/common/endorsed"
一共有兩處,都要修改,修改完之後保存,退出,重新啟動Eclipse,這一步很重要,一定要做,不然的話你在Lomboz中啟動TOMCAT的時候會再現很多莫明其妙的異常的

6:調出Lomboz各個菜單
啟動Eclipse,然後點擊windows->Customize Perspective,在出現的對話框中的Shortcuts頁面中首先選中左邊面板中的Lomboz J2EE Wizards,這時右邊的面板中會出現很多選項的,同時也把它們各項前面的對鉤打上。
然後在這個Shortcuts面板中改變Submenus:的值,選擇Show View,接著在出現的面板的左邊里選中Lomboz J2EE,同時也要把它前面的方框中打上對鉤。
最後是更換Customize Perspective對話框中的面板到Commands這一頁:
在Commands這一頁中選定Lomboz Actions同時也把它們各項前面的對鉤打上。
所有的設置完畢。
這樣一切做完之後,Eclipse和Lomboz的環境就配置好了,你可以進行開發各種程序了。
個人體會:
可能在第5步中有些機器上可以不做,因為有不同的TOMCAT版本,不過我機器一定要改了才行,不然的話是不能正常啟動TOMCAT的。我個人使用 TOMCAT4.1.30版的,是因為我覺得這個版本的比較小,運行起來也比較快,比5.0以上版本的要快多了,而且也要相對穩定一些(個人看法,不代表其它人的),還有就是對於Eclipse 3.0的,可以參照上面的說明進行配置,基本上也可以行得通的,沒有什麼比較大的問題。

I. eclipse怎麼操作運行配置

eclipse怎麼操作運行配置,這里分享下解決方法。

1、首先在電腦中,解壓Eclipse壓縮包。

J. 流暢運行eclipse電腦需要很高配置嗎

不需要特別高,但是內存要夠大,CPU要夠強。

閱讀全文

與eclipse電腦配置要求相關的資料

熱點內容
電腦能回復出廠設置 瀏覽:181
電腦開機慢沒網路手機有網路 瀏覽:840
電腦恢復出廠設置後還能恢復么 瀏覽:123
蘋果電腦重力感應設置 瀏覽:217
電腦字體過大如何處理 瀏覽:413
電腦卡為什麼會響 瀏覽:836
中國3dmax免費模型網站 瀏覽:14
電腦硬碟啟動順序設置 瀏覽:447
蘋果沒卡下軟體老是要登錄 瀏覽:759
網上哪個牌子的組裝電腦比較好 瀏覽:388
電腦開機出現紅燈一直亮 瀏覽:266
電腦是多少瓦的 瀏覽:585
蘋果電腦系統可以裝嗎 瀏覽:470
配置高的平板電腦性價比高 瀏覽:648
電腦如何設置可以讓手機連wifi 瀏覽:209
列印機怎麼連接電腦不用usc 瀏覽:705
電腦無線網連接不上去 瀏覽:418
電腦上app怎麼設置大小 瀏覽:398
怎麼設置不鎖電腦英文 瀏覽:365
電腦4核處理器多少錢 瀏覽:213